More CubieBoard Adventures

So, I’m going to identify a couple of initial issues I’ve discovered with the default Linaro/Lubuntu Server image on the CubieBoard, and document how I’m getting around them, mostly for my own personal future reference, just so that if I have to start from scratch again, I have a frame of reference.

So, problems?

  • HDMI Overscan is far too much.  I can’t see the top or bottom couple of lines of the console display, and I’d say there’s probably 4 characters to the left missing (so, presumably about 4 missing on the right, too).
  • It doesn’t detect my WiFi dongle.  I’m using a TP-Link TL-WN725N Version 2 which uses the RTL8188EU chipset.  This was actually detected just fine and worked perfectly in a couple of the Android images I’d tested.  This version of the dongle was so much of a bugger to try to get working on the Pi that I gave up and just used a Netgear dongle instead that was automatically detected.

Some of you may note that I’m making some absolute beginner Linux mistakes here.  As I mentioned in another article, I’ve actually been using Linux since 1996, but for the about last decade I’ve not really had to delve that deeply into it.

The last few years have simply been a case of installing from the DVD image, getting Apache, PHP & MySQL up and running (and whatever other services I needed), it’s often been wired straight into a network on a device that the kernel already supports, and everything’s just worked.

Security, and hardcore “fiddling” was never really an issue, as they were just private servers on a LAN for web development and code testing.  Like I said, everything just worked.

Now, thanks to the Raspberry Pi and the CubieBoard, I’m sort of rediscovering and relearning it all over again.  It’s been at least a decade since I last remember issuing most of these commands.

Anyway, once the two problems I listed above are out of the way, I can go ahead and start figuring out what else may be missing.  I’m assuming it comes with MySQL preinstalled, so I’ll have to get rid of that and install MariaDB (apparently that’s what we’re using now that Oracle killed the MySQL community).

The HDMI thing isn’t really a massive issue, as I ultimately won’t be using this with a monitor anyway.  It’ll basically just be sat there powered a USB charger, toting the WiFi dongle, but it’s annoying me, and if I do ever have to hook it up to a monitor to make changes that would be difficult to do via SSH, I want it to already look right.

With Rasbmc on the Pi, it was easy.  XBMC has display calibration built in, and you just push a few buttons on the remote to sort it, and even using a Raspbian image to boot up, on a HDMI monitor, the overscan was already set perfectly when going into a TV.

Argh, screw it, time to plug in a regular network cable and do a quick “shutdown -r now” in order to be able to SSH in and actually see everything in the console.

Actually, first job, change the alias for “ls” from…

alias ls='ls --color=auto'


alias ls='ls -aF --color=auto'

Done.  I hate that it doesn’t show me .files by default.  Right, to business.

Fixing the HDMI Overscan

Ok, this turned out to be easy enough, I cheated.  After spending about 30 minutes googling and getting nowhere (aside from a couple of Raspberry Pi /boot/config.txt suggestions – a file that does not exist in Lubuntu), I couldn’t find anything.

In the end, as I said, I cheated.  I just turned overscan off on the TV.

I was hoping to find a way that I could configure this from the device itself, so that it wouldn’t matter what TV I hooked it up to, I’d be able to reconfigure it as needed on the fly (purely for curiosity’s sake), but it’s late, and now I can forget about it until and unless it becomes an issue again.

Setting up the TP-Link TL-WN725N WiFi Dongle

This, as I mentioned above, was an absolute bugger on the Raspberry Pi, in both Raspbian and Raspbmc.  I did actually manage to get it to successfully detect the dongle, and it would scan the network, but it simply would not log onto my WiFi network at all, no matter how it was configured.

So, I switched it out for my Netgear dongle, which worked straight out of the box.  Plug it in, reboot, enter the SSID & password for my WiFi, and it was up and running.

This time, I don’t have another Netgear dongle I can grab, so I have to get the TP-Link dongle working.

Once my MicroSD cards arrive, I might have a go at setting up Cubian on one of them, as it claims to support the RTL8188EU chipset already (.  The current decision to use Lubuntu is not set in stone, it’s simply the easiest distro to flash to the NAND without a MicroSD card.

The Next Day: Well, I’ve deleted a lot of stuff from below that I posted yesterday.

While trying to set it up, I had a regular network cable plugged into the NIC so I could do everything from the comfort of my PC using SSH, and once the WiFi dongle started getting an IP address I thought I had it cracked, but nope.  As soon as I unplugged the network cable and rebooted, it couldn’t connect again, no matter what I did.

It seems it was talking to the DHCP server and getting the IP address for the WiFi dongle over wired LAN.  Back to square one.

I’ve left in some links n’ whatnot purely as reference.

Ubuntu WifiDocs/WiFiHowTo

sudo apt-get install wireless-tools

The lsusb command presents me with…

Bus 002 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.

depmod -a
modprobe 8188eu

It suddenly strikes me that I have not yet done the following…

apt-get update
apt-get upgrade

I have now.

Using the Command Line Interface @ Fedora Docs

Remember, my wired LAN is still hooked up at this point.

My /etc/network/interfaces file currently looks like this…

auto lo eth0 wlan0
iface lo inet loopback
iface eth0 inet dhcp
iface wlan0 inet dhcp

And executing the following sequence of commands…

iwconfig wlan0 essid MY_NETWORK_SSID key MY_NETWORK_KEY
ifconfig wlan0 up
dhclient wlan0

Results in…

wlan0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr: Bcast: Mask:

And a bunch of other stuff, but MY WIRELESS DONGLE HAS AN IP ADDRESS!  Obviously, I’ve removed the MAC address, heh.

Doing ifdown wlan0 and then ifup wlan0 makes it automatically grab an IP address again.

Rebooting resets and loses the SSID and password, so now I just need to figure out how to make all this happen automagically when I turn the thing on.

So, turned out it was going to be an absolute bugger on the Cubie, too.

Now, I’m thinking I go buy a couple of MicroSD cards, so I can try a more useful distro, and then flash it to the NAND.